Can't submit new version for review - "Missing Required Information"


#1

I’m trying to submit a new version of our extension for review.
Already did this 20+ times, but this time when I do I get:

Missing Required Information
You are missing some required information. Please go back to Local Test and fill the fields in Version Details marked with *.`

Screenshot:

It goes without saying, there are no visible empty fields marked with *, and I submitted this extension 20+ times before without problems with the same info


#2

Check for

  • privacy policy
  • EULA

Should be optional, but iot’s wise to have a privacy policy

Check for all Image Assets having an image

Sometimes they don’t clone right between versions


#3

@BarryCarlyon is right, the error says check the fields in the “Version Details” tab, the key point to make is you’re in the wrong place compared to your screenshot.


#4

Thanks for your prompt reply

The screenshot was to show the error popup.
Here are three screenshot showing all parameters in the Version Details tab:




#5

Okay, this may be a long shot, got back to “local test” not “hosted test”, when you are in Local Test, re-upload your images. Then again make sure you have filled all fields.

There was an issue in the past that you could upload when in hosted test which would not “work” when it came to submission. Just make sure you are in Local Test before doing this.


#6

Also check that everything is correct in asset hosting.

In case you have enabled a view and not given a HTML file to load or something


#7

They all look fine :frowning:


#8

Tried that, re-uploaded all images and checked all fields again, still not working.