Clips Discovery Autoplay Off?


#1

Hi, I’m using the clips discovery feature as described here: https://dev.twitch.tv/docs/v5/guides/clips-discovery/

The default for the second example (fetching the top clips) is set to 10 clips, and when embedded they all start playing automatically at the same time.

I’ve added this to the example code:

clipItem.innerHTML = clip.embed_html.split("><")[0] + " autoplay='false'><" + clip.embed_html.split("><")[1];

So the generated iframe has autoplay set to false but the clip still plays automatically, not sure why.

Also, here is a fiddle that demonstrates this issue:

http://jsfiddle.net/6mSuK/1114/

Notice how it autoplays, disregarding the autoplay option in the iframe parameters. Same happens when you set muted=‘true’.

Could someone let me know how to stop the autoplay?

Thanks a lot


Clips Découverte Autoplay (zuhayrx)
#2

figured it out, need to edit the query string not add a parameter to the iframe.


closed #3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.