Did Something Happen With Twitch Today?

I would post this in Off-topic but it is read only, I swear I must be crazy. My application stopped working today. I saw that I was getting error from my request to Twitch API Helix. It was an Error along the lines “No Authorization Token” which I had never gotten before. I started following the steps to get an OA Token, refresh it if needed, and implement it all into my code. However when running the code to test for error it started working, before I had implemented the Token. I’m confused if it just randomly started working or maybe Twitch API was having some problems.

Edit: I forgot to mention I removed all the code I added since I got the error and it works.

-Thanks

Over 2 months ago Twitch announced that all Helix endpoints will require both a Client ID, and an OAuth token. https://discuss.dev.twitch.tv/t/requiring-oauth-for-helix-twitch-api-endpoints

Today was the 2nd scheduled window, this one lasting 4 hours, in the rollout of the changes. You got that error because you haven’t updated your code to be ready for those changes, and because of the gradual rollout when the 4 hour window ended your code started working again.

Ah I see, thank you! On another note, is there documentation on what a failed OAuth token validation response looks like?

The validation endpoint https://id.twitch.tv/oauth2/validate will return this for expired/invalid tokens:

{
  "status": 401,
  "message": "invalid access token"
}
1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.