Eventsub Webhooks stopped incoming

I subscribed a customer via eventsub webhook and it worked fine but have stopped receiving them. I hit the /eventssub/subscriptions endpoint and see that their webhook is "status": "enabled". Any ideas on how to further debug this issue? (it has been a few hours since action was performed)

Check your server access logs for HTTP requests

Are you using LetsEncrypt as a certificate SSL certificate provider?

See this post which describes a solution

Thanks for the idea - but dont think this is it as it has worked fine for the past 3 months and nothing changed from our side around that.

On Septmebr 30th. LE certs did a weird. Hence mentioned LE Certs

Are you using something like cloudflare? As Cloudflare will block the requests due to thinking they are spam/malisious/robotic attacks.

My eventsubs are working fine so we are looking at environtmental issues to your setup.

So you’ll need to check your apache/nginx logs to see if it’s actually hitting your server or not as well as any firewall logs