Getting Parameter redirect_uri does not match registered URI error

Hello all,

I have a problem with the redirect_uri parameter, i don’t understand why it never corresponds to the one given in the Twitch Developers Console.

here is the js code until now :

and this is what I have entered in the developers console :

I get this link :

[type or paste code here](https://id.twitch.tv/oauth2/authorize?response_type=token&client_id=i02aildra1ymw95mcfx3c3zfwyt7b0&redirect_uri=http%3A%2F%2Flocalhost%3A8080%2F&force_verify=true&scopes=bits%3Aread%20channel%3Amanage%3Apolls%20channel%3Amanage%3Apredictions%20channel%3Amanage%3Aredemptions%20channel%3Aread%3Apolls%20channel%3Aread%3Apredictions%20channel%3Aread%3Aredemptions%20channel%3Aread%3Asubscriptions)

It seems to work but after authorizing the application I get this message :

Capture2

and localhost does not allow connection with the error " Parameter redirect_uri does not match registered URI ".

I’ve also tried with “http://127.0.0.1:8080/” with and without slash and i checked my client ID but i still have this error.

Sorry if the answer has already been given, I searched in others similar topics but I did not find any solutions.

Thanks for your help !

Your center screenshot is the testing base URI for an extension.

Not the redirect URI for the oAuth client.

So if your application is an extension then you are adding the redirect URI in the wrong place. Top right of the extensions UI is [extension settings]

In there you will find the OAuth Redirect URL field. That is where you should be setting the Redirect

If you have created an Extension Client ID in error, then you need to create a “regular” Application ClientID instead.

And that only has the one page

I knew it would be something like this :upside_down_face: I didn’t see the field. thanks for your help !

BTW: The field you have currently populated is the “where does my Extension get served from in localtest”

Ok, I see. Thanks !