How do i know if i'm using V3 APIs?


#1

Following up on this announcement, how can i make sure that i don’t use V3 API? How can i identify one? I know this is a silly question, but it’s not that obvious to me.


#2

V3/V5 is api.twitch.tv/kraken

When using this API you send a v3 or a v5 in the header to choose which version. v3 is the current default if you don’t specify a header

New API is api.twitch.tv/helix


#3

So I’m fine if i use an API that is either:

or

Right?


#4

Yup.

In theory when v3 is removed you won’t need the v5 header. But it’s good practice to include it