Mobile View Very Dark/Off Center


#1

For some reason the mobile view on the twitch dev rig has a very dark background by default, why is this? I don’t have any CSS that is setting background color, and I have it set to ‘Light’ theme.

Also, when in landscape mode, it anchors the view to the right side of the screen. I’m having trouble figuring out why this is.


#2

Then set a background color?

you need to handle this for if a user changes from light to dark more, if you are not setting a background color on your extension itself you are at the mercy of any changes Twitch does or does not do, so the correct thing to do is to set a background color on your extension. And add a color change for dark/light mode, if you want to offer two different themes

Because thats what it looks like, to the left would be the stream you are watching/have open

here is a screenshot from bluestacks


#3

I don’t have any CSS that is setting background color, and I have it set to ‘Light’ theme.

I didn’t set any background colors on purpose, so why is it defaulting to a translucent dark grey background? Once moved to hosted test, the dark color is not there so why does it exist on the Dev Rig? Feels like a bug to me.

Because thats what it looks like, to the left would be the stream you are watching/have open

That makes sense. It may be useful to indicate that when previewing the view on the Dev Rig. I’m not sure many people would deduce that if they have never seen a mobile extension in landscape orientation before.


#4

The docs show clear examples of what a mobile extension looks like in landscape orientation https://dev.twitch.tv/docs/extensions/designing


#5

Ah ok, don’t know how I missed that. Would still encourage adding an indicator to the dev rig, but I think that is less important.

Let me know if you guys have any more thoughts on the dark background.


#6

If you set nothing then you get unexpected behavior, as has occurred. My advice is to set background color and not rely on Twitch doing what you expect it to, bugs or no bugs in the rig’s behavior.

Yes it’s probably a rig bug, but don’t rely on Twitch always being white background, and you using transparent/no set CSS.

See also:

If you use a transparent background, and you get this bug, none of your text is going to be readable, because you didn’t set a none transparent background.