New developer rig: Cannot configure path to OpenSSL


#1

Running on Windows 10. I have the new rig cloned from Github and running configure.cmd seemed to do as expected. The problem is with running make-cert.cmd which results in “Cannot configure path to OpenSSL.” Did I miss installing a required package or something?


#2

You need to install Git for Windows and then choose OpenSSL as SSL Library.
Windows doesnt have OpenSSL installed by default


#3

That did the trick. Thanks!


#4

Hey I am having this same issue - can you please tell me if you did anything else after installing Git for Windows? I already had it installed, but reinstalled and double checked that the option to install openssl was selected. I can see the files on my computer in the Git installation folder, but configure.cmd is still returning the same error message :confused: Thanks!

UPDATE: I resolved this - looking through the .cmd files it seemed that they were looking specifically on the OS’s installed drive for openssl in the Git folder. My copy of Git was on a separate drive so the install couldn’t find it. I resolved this by reinstalled Git on the same drive as my OS, however I think it would also work if you just change the drive it’s looking for (or the path entirely) in the .cmd file doing the check.