Sending message to chat from EBS

Hello ! I’m trying to send a message with my extension’s EBS and I need some help !
I think I’m doing it right :

generateJwt(channelId: string): string
    const payload: EbsJwt = {
      exp:Math.floor( / 1000) + (60 * 60),
      user_id: '656175601',
      channel_id: channelId,
      role: 'external'

   return jwt.sign(payload, Buffer.from(secret, 'base64'), { algorithm: 'HS256' });

async sendChatMessage(channelId:string, message:string){
    const url = twitchApiConfig.url.endpoints.twitchChat + channelId;
    try {
      // Perform POST Request
      await superAgent
        .send({text:message, extension_id:secretInformation.clientId, extension_version:'0.0.1'})
        .set('Client-ID', secretInformation.clientId)
        .set('Authorization', 'Bearer ' + this.authService.generateJwt(channelId))
        .set('Content-Type', 'application/json');
    } catch (error) {

I always get this error :
status:401,message:missing authorization argument
Every secret and needed information is already good and wworking in other parts of my project.

Can anyone help ?

Thanks !

There is an outage on this API at this time.

Can you confirm/state your clientID for me?

The old API works but the new one doesn’t
So I’m collecting clientID’s for reporting to Twitch

I sent it to you in DM

ClientID’s are considered public…

oups… Better safe than sorry ! :smiley:

The problem may be resolved if you can give it another whirl?

Oh ! It worked ! Thank you !
If i read correctly, twitch api is changing its way of sending message ? Should I do somethink else for that ? is there a link or will it be transparent on my side ?

Err you are already using the “new Extension Chat API” as that was the one that was broken

Which is this one:

OK, That was just to be sure ! Thanks a lot for your help !

Hello there, it’s me again !
I’ve encountered another problem : my extension can send chat message on the stream account owning it, no problem here… but when trying to send chat message on another chat (from an account registered in the beta), it generates the same error that I had in the beggining…
Is this still the same problem from before ? If so, when will this be solved ?
Thanks in advance,