Stuck in a loop with extension review policy


#1

The Twitch approval process is designed to make you fail. There is no way out of this approval loop.

DON’T WASTE YOUR TIME

If pull JQuery as requested, you are rejected for pulling JQuery from an external CDN. If you include JQuery as part of the package, you are rejected for not loading JQuery from specified path.

— Rejection 1 —

Policy 2.9
Your Extension includes HTML files that are not correctly loading the Twitch Extension Helper. Either it is not present, or it is not being loaded first. Please make sure that the Twitch Extension Helper is included from our CDN and is being loaded before all other Javascript within each HTML file of your upload.

<script src=“https://code.jquery.com/jquery-3.3.1.min.js” integrity=“sha256-FgpCb/KJQlLNfOu91ta32o/NMZxltwRo8QtmkMRdAu8=” crossorigin=“anonymous”>

– Rejection 2 —

Policy 2.8
Your Extension is attempting to load external files, either from a CDN or other private server, and this will cause your Extension to not function in production. Please make sure that all files that are required by your Extension to function are included in your upload.

You are pulling Jquery from an external CDN for all views.


#2

So you did download jquery-3.3.1.min.js then include that file in the zipped package you uploaded to twitch?

then just reference it using <script src="js/jquery-3.3.1.min.js"></script>

I have extensions which include JQuery, React Apps, Vue Apps and much more.


#3

Also 2.9 means you’re not doing this

<script rel="preload" src="https://extension-files.twitch.tv/helper/v1/twitch-ext.min.js"></script>

On EVERY html page you upload, it has nothing to do with JQuery


#4

This is exactly what I did, and I get the following rejection as a result:

Policy 2.9
Your Extension includes HTML files that are not correctly loading the Twitch Extension Helper. Either it is not present, or it is not being loaded first. Please make sure that the Twitch Extension Helper is included from our CDN and is being loaded before all other Javascript within each HTML file of your upload.

<script src=“https://code.jquery.com/jquery-3.3.1.min.js” integrity=“sha256-FgpCb/KJQlLNfOu91ta32o/NMZxltwRo8QtmkMRdAu8=” crossorigin=“anonymous”>


#5

Yes I am including the twitch script in the HTML header.


#6

THIS:

Has nothing to do with THIS:

THIS is an example of one of my html pages…

<!DOCTYPE html>
<html lang="en">
  <head>
    <meta charset="utf-8">
    <meta http-equiv="X-UA-Compatible" content="IE=edge">
    <meta name="viewport" content="width=device-width,initial-scale=1.0">
    <link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Roboto:100,300,400,500,700,900">
  </head>
  <body>
    <noscript>
      <strong>We're sorry but top-ant doesn't work properly without JavaScript enabled. Please enable it to continue.</strong>
    </noscript>
    <div id="app"></div>
    <script rel="preload" src="https://extension-files.twitch.tv/helper/v1/twitch-ext.min.js"></script>
    <script src="jquery.min.js"></script>
  </body>
</html>

#7

This is the EXACT copy of the text from my rejection:

Policy 2.9
Your Extension includes HTML files that are not correctly loading the Twitch Extension Helper. Either it is not present, or it is not being loaded first. Please make sure that the Twitch Extension Helper is included from our CDN and is being loaded before all other Javascript within each HTML file of your upload.

<script src=“https://code.jquery.com/jquery-3.3.1.min.js” integrity=“sha256-FgpCb/KJQlLNfOu91ta32o/NMZxltwRo8QtmkMRdAu8=” crossorigin=“anonymous”></script>


#8

Recheck all the HTML files you have included in your Zip file to ensure they have the Twitch Ext helper as noted, and don’t try to call scripts from external CDN’s

Edit: oh I also modified the title to make it more easier for others with a similar issue to find


#9

This is my HTML header

<head>
  <title>Viewer Page</title>
  <script rel="preload" src="https://extension-files.twitch.tv/helper/v1/twitch-ext.min.js"></script>
  <script src="jquery-3.3.1.min.js"></script>
  <script src="viewer.js" type="text/javascript"></script>
</head>

Rejected 2.9

This is my other rejection.

<head>
  <title>Viewer Page</title>
  <script rel="preload" src="https://extension-files.twitch.tv/helper/v1/twitch-ext.min.js"></script>
  <script src="https://code.jquery.com/jquery-3.3.1.min.js" integrity="sha256-FgpCb/KJQlLNfOu91ta32o/NMZxltwRo8QtmkMRdAu8=" crossorigin="anonymous"></script>
  <script src="viewer.js" type="text/javascript"></script>
</head>

Rejected 2.8


#10

Throw your zip file up either here or via the discord and we can help debug.

We are assuming you went to local test, uploaded and resubmitted from there.


#11

Also do you only have one html file? this has to be the same on ALL html files.

We are also assuming you tested this in hosted test before submitting it for review as this would have thrown up errors


#12

Yes hosted test works.


#13

feel free to add me to your testing whitelist -> LuckyNoS7evin

Then I can install and have a look for you.


#14

Zip FIle is here:
https://twitch-mess.s3-eu-west-1.amazonaws.com/push.zip


#15

You have inline styles. Thats not allowed.

Move your CSS to a CSS file and include said file


#16

not just the style tag in the head either there is also style on the svg


#17

My problem so far has been jQuery. I can add the styles in a separate CSS and even place the SVG in an external file. But my rejections to this point have been all JQuery related.


#18

The second/repeated email with the rejection may have cited the wrong issue due to the previous issue being jQuery. shrug


#19

If we can’t use inline styles, can we not use background images then?

Part of my load script is to set the background-image css style for the poster. To maintain the correct aspect ratio I’m using background-size:cover.


#20

That should be allowed, as dynamic zoom of overlay extensions use JS to set CSS (I have this active in an extension)