Upcoming OAuth scope requirements for PubSub


#1

To provide better account security for Twitch users, we are updating a few PubSub topics with more appropriate OAuth scopes. The table below indicates which topics are affected, the current scope, and the new requirement. These scopes can be added at your convenience and will be required starting on or after January 20, 2020.

Topic Current Scope New Scope
channel-bits-badge-unlocks Any scope bits:read
channel-bits-events-v1 Any scope bits:read
chat_moderator_actions Any scope channel:moderate

Note that chat_moderator_actions was not formally documented other than within this discussion, however, it will require a new scope as indicated above. This topic should be considered officially supported.

Also note that channel-commerce-events-v1 is now considered deprecated as it refers to a product no longer available and will be decommissioned starting on or after January 20, 2020.

Please feel free to include comments and questions below.