Utc_offset ignored when using Get Channel Stream Schedule


Has anyone been able to get a stream schedule in the correct time zone specified by the utc_offset parameter? I’m able to get the schedule without issue, but no matter what value I supply to utc_offset, the times are always in GMT. Based on the documentation, I believe I should be able to specify “-420” to convert GMT to PDT. The requests do not produce any errors, they are simply in the wrong/default time zone. I did not see a bug report filed, so I’m wondering if I’m doing something wrong. Any help would be appreciated.

Thank you.

The purpose of the utc_offset is to stop an event that repeats
And bridges the “week boundary” it’s not returned as the first event.
It won’t modify the start_time of events in the payload itself. You just feed that to a date/time parser/formatter anyway, rather than show it verbatim.

It just stops an event appearing at index 0 that has already occured.
Or conversely ensures an event appears at index 0 which hasn’t occured yet but would be removed per a 0 utc_offset

Usually makes more sense when also feeding in a start_time query parameter.

From the docs:

This is recommended to ensure stream segments are returned for the correct week

TLDR: I don’t think it’s bugged, it’s just not an untitive thing.

OK. Looks like I just misunderstood the proper use of that parameter. I’ll just do the time zone conversion with a timedelta.

Thank you very much for clarifying.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.